通达信免费指标:买卖位置

图片[1]-通达信免费指标:买卖位置-期货圈
短线操作顶底可提前预知
N1:=38;
N2:=8;
N3:=7;
X1:=100*(HHV(HIGH,N1)-CLOSE)/(HHV(HIGH,N1)-LLV(LOW,N1));
VAR1:=100*(HHV(HIGH,N2)-CLOSE)/(HHV(HIGH,N2)-LLV(LOW,N2));
VAR2:=100*(HHV(HIGH,N3)-CLOSE)/(HHV(HIGH,N3)-LLV(LOW,N3));
VAR3:=VAR1-X1;
VAR4:=X1-VAR1;
柱状:STICKLINE(X1>=0,0,VAR2,1,0),COLORGREEN;
{主力介入区:STICKLINE(VAR3<0,0,VAR4,1,0),COLORRED;}
STICKLINE(X1>=0,0,VAR1,1,0),COLORBLUE;
{主力出货区:STICKLINE(VAR4<0,0,VAR3,1,0),COLOR00FF00;}
{DRAWICON(FILTER(位置线>95,1),105,1);}
{DRAWICON(FILTER(位置线<2,1),-5,2);}
位置线:X1,COLORWHITE,LINETHICK1;
准备卖出:位置线<2,NODRAW,COLORGREEN;
准备买入:位置线>95,NODRAW;
{风险值:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);}
第二天卖出:3,COLORRED,LINETHICK1;
第二天买入:97,POINTDOT,COLORBROWN;
中轨:=MA(CLOSE,12);
上极限:=中轨+2*STD(C,12);
下极限:=中轨-2*STD(C,12);
{天地撞击信号BS}
DRAWICON(CROSS(C,下极限),5,7);
DRAWICON(CROSS(上极限,C),95,8);
DRAWTEXT_FIX(C>O,0.01,0.9,0,'微信订阅号:翔博软件工作室'),COLORffffff;
{短底部含未来}
Q_1:=C-REF(C,1); 
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6); 
Q_3:=CROSS(EMA(C,19),EMA(C,7)); 
Q_4:=CROSS(EMA(C,7),EMA(C,19)); 
Z1:=L=LLV(L,BARSLAST(Q_3)+1); 
Z2:=LLV(L,BARSLAST(Q_3)+1); 
Z3:=H=HHV(H,BARSLAST(Q_4)+1); 
Z4:=HHV(H,BARSLAST(Q_4)+1); 
Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0); 
Y1:=H=HHV(H,BARSLAST(Q_4)+1); 
Y2:=HHV(H,BARSLAST(Q_4)+1); 
Y3:=L=LLV(L,BARSLAST(Q_3)+1); 
Y4:=LLV(L,BARSLAST(Q_3)+1); 
Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0); 
XY1:=LLV(Q_2,2)=LLV(Q_2,7) ; 
XY2:=COUNT(Q_2<0,2); 
XY3:=CROSS(Q_2,MA(Q_2,2)); 
XY4:=REF(Q_B,1)<REF(Q_B,2); 
XY5:=Q_A>REF(Q_B,1); 
买进:=(XY1 AND XY2 AND XY3) AND XY4 AND XY5; 
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0); 
超短1:=REF(TJ,1)=0 AND TJ>=1; 
DRAWTEXT(FILTER(超短1>0,1),10,'底');
© 版权声明
THE END
喜欢就支持一下吧
点赞10 分享
评论 抢沙发
头像
欢迎您留下宝贵的见解!
提交
头像

昵称

取消
昵称表情代码图片